Test NG - Question | Selenium Forum
S
sirisha_gadde Posted on 07/01/2021

I am learning Test NG modules 

I have JRE System Library (Java SE - 14) in the module path /Latest Eclipse version  and Test NG 7.3 

I have tried with 7.0.0 test NG version too but the result was the same 

when I add Test NG module to module path I get this error during the time of execution 

Error occurred during initialization of boot layer
java.lang.module.FindException: Unable to derive module descriptor for C:\Users\siris\.p2\pool\plugins\com.beust.jcommander_1.78.0.jar
Caused by: java.lang.IllegalArgumentException: com.beust.jcommander.1.78.0: Invalid module name: '1' is not a Java identifier

 

When I move the TestNG library to class path ( got this from stack overflow ) /

THe module is not recognized 

all the annotations are all unrecognized 

How to resolve this issue 

can you help please 

I am watching the videos may be from 2018 


A
Ashish Replied on 07/01/2021

Please do not use jre 14

Install JDK 8


S
sirisha_gadde Replied on 07/01/2021

Thank you Will try , JDK 8 too .

I tried some thing removed the module info that was created during the Project creation and it worked 

Please close the issue 


Related Posts