Getting error while installing TestNG in Eclipse LUNA version | Selenium Forum
A
Abhiram Vajrapu Posted on 28/09/2021

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.m2e.archetype.common,1.7.0.20160603-1931
No repository found containing: osgi.bundle,org.eclipse.m2e.core,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.core.ui,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.discovery,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.editor,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.editor.xml,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.jdt,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.jdt.ui,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.launching,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.lifecyclemapping.defaults,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.logback.appender,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.logback.configuration,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.maven.indexer,1.7.0.20160603-1931
No repository found containing: osgi.bundle,org.eclipse.m2e.maven.runtime,1.7.0.20160603-1931
No repository found containing: osgi.bundle,org.eclipse.m2e.maven.runtime.slf4j.simple,1.7.0.20160603-1931
No repository found containing: osgi.bundle,org.eclipse.m2e.model.edit,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.profiles.core,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.profiles.ui,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.refactoring,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.scm,1.7.0.20160603-1933
No repository found containing: org.eclipse.update.feature,org.eclipse.m2e.feature,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.importer,1.7.0.20160603-1933
No repository found containing: org.eclipse.update.feature,org.eclipse.m2e.logback.feature,1.7.0.20160603-1933
No repository found containing: osgi.bundle,org.eclipse.m2e.workspace.cli,0.3.1


A
Ashish Replied on 30/09/2021

Please try on latest eclipse version and install testng 7